Tag Archives: sound devices

audiodg.exe high cpu usage

This problem happened after I upgraded my ASUS A43SV BIOS. Suddenly, my Windows 7 is getting slower and slower when playing any sound (including Windows 7 system sound notification). Checking on Process Explorer, it is audiodg.exe that eat most of the CPU power and the Windows application that need to play sound. Even playing music with foobar2000 slow down Windows 7, not to mention when you are playing Youtube video using Firefox (Firefox + Flash + audiodg.exe = snail speed Windows).

windows normal audiodg.exe

normal audiodg.exe

(I can confirm it is BIOS problem because I do dual-boot and my Ubuntu also slowed down)

Of course I can downgrade my BIOS into recently working BIOS, but I’m looking for more “generic” solution.

So here it is:

  • right click on your “Speakers” on your Windows 7 tray icon
  • windows speakers right click menu

    right click on Speakers icon

  • Choose Playback Devices
  • New window will open. Double click on your playback device that has green checkmark
  • windows list of active sound playback devices

    Default playback devices. Double click it.


  • Choose “Enhancements” tab
  • click on “Disable all sound effects
  • windows playback devices disable enhancements

    Disable all sound enhancement

  • Click OK
  • reboot your Windows 7 (I don’t know if this last step necessary or not)

Tested on: Windows 7 64bit, ASUS A43SV, official BIOS version K43SVAS.317

If this trick doesn’t work, you can always easily downgrade the BIOS using WinFlash utility from ASUS.